Kali Linux metasploit upgrade error

Obviously there is something wrong between dpkg-deb (a program, which is part of the debian package management used by apt-get) and tar (which is packing/unpacking files from/into single archives).

Now the dpkg-deb is calling tar with an unsopported option, so somehow there is a version mismatch between those programs.

You can run this, to try solve this issue:
'apt-get clean' or 'aptitude clean'

software update result



terminal command  update error get





root@lhackg:~# apt-get update && apt-get upgrade && apt-get dist-upgrade
Get:1 http://dl.google.com stable Release.gpg [198 B]
Get:2 http://dl.google.com stable Release [1,347 B] 
Get:3 http://ppa.launchpad.net precise Release.gpg [316 B] 
Get:4 http://dl.google.com stable/main amd64 Packages [1,211 B] 
Get:5 http://ppa.launchpad.net precise Release [11.9 kB] 
Get:6 http://dl.google.com stable/main i386 Packages [1,217 B] 
Get:7 http://ppa.launchpad.net precise/main Sources [27.2 kB] 
Get:8 http://ppa.launchpad.net precise/main amd64 Packages [16.8 kB] 

The following packages will be upgraded:
metasploit nmap zenmap
3 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
7 not fully installed or removed.
Need to get 5,987 kB/170 MB of archives.
After this operation, 4,096 B of additional disk space will be used.
Do you want to continue [Y/n]? y

Unpacking replacement metasploit ...
dpkg-deb (subprocess): decompressing archive member: internal gzip read error: '<fd:4>: incorrect data check'
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing /var/cache/apt/archives/metasploit_4.8.1-2013120401-1kali0_amd64.deb (--unpack):
subprocess dpkg-deb --fsys-tarfile returned error exit status 2
insserv: warning: current start runlevel(s) (empty) of script `metasploit' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `metasploit' overrides LSB defaults (0 1 6).
Preparing to replace zenmap 6.40-1kali1 (using .../zenmap_6.40-1kali2_amd64.deb) ...
Unpacking replacement zenmap ...
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Errors were encountered while processing:
/var/cache/apt/archives/metasploit_4.8.1-2013120401-1kali0_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Completed successfully

'apt-get clean' worked! Simple. I run upgrade && update after and it was a complete success.
SHARE

About Lasha Gogua

    Blogger Comment
    Facebook Comment

0 comments:

Post a Comment