Pip list error correction for Python in Kali Linux

root@Lh4cKg:~# pip list
adns-python (1.2.1)
Warning: cannot find svn location for apsw==3.7.6.3-r1
apsw (3.7.6.3-r1)
apt-xapian-index (0.45)
argparse (1.2.1)
Brlapi (0.5.7)
chardet (2.0.1)
Cheetah (2.4.4)
dissy (9)
distorm3 (3)
distribute (0.6.49)
Django (1.5.1)
Magic-file-extensions (0.2)
MarkupSafe (0.15)
MySQL-python (1.2.5)
netaddr (0.7.7)
netlib (0.9.1)
NfSpy (1.0)
numpy (1.6.2)
PIL (1.1.7)
Pillow (2.3.0)
pip (1.5)
psycopg2 (2.4.5)
pyasn1 (0.1.3)
pycrypto (2.6)
pymssql (1.0.2)
pytz (2012c)
pyusb (1.0.0a3)
PyX (0.11.1)
scapy (2.2.0)
scipy (0.10.1)
Exception:
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pip-1.5-py2.7.egg/pip/basecommand.py", line 122, in main
    status = self.run(options, args)
  File "/usr/local/lib/python2.7/dist-packages/pip-1.5-py2.7.egg/pip/commands/list.py", line 80, in run
    self.run_listing(options)
  File "/usr/local/lib/python2.7/dist-packages/pip-1.5-py2.7.egg/pip/commands/list.py", line 142, in run_listing
    self.output_package_listing(installed_packages)
  File "/usr/local/lib/python2.7/dist-packages/pip-1.5-py2.7.egg/pip/commands/list.py", line 151, in output_package_listing
    if dist_is_editable(dist):
  File "/usr/local/lib/python2.7/dist-packages/pip-1.5-py2.7.egg/pip/util.py", line 347, in dist_is_editable
    req = FrozenRequirement.from_dist(dist, [])
  File "/usr/local/lib/python2.7/dist-packages/pip-1.5-py2.7.egg/pip/__init__.py", line 231, in from_dist
    assert len(specs) == 1 and specs[0][0] == '=='
AssertionError

Storing debug log for failure in /root/.pip/pip.log

I think it is because the distribute package is out of date. Certainly the following fixed it for me:
root@Lh4cKg:~# sudo pip install --upgrade distribute

Done!
SHARE

About Lasha Gogua

    Blogger Comment
    Facebook Comment

0 comments:

Post a Comment